<!DOCTYPE html>
<html lang="en" class="no-js">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="http://gmpg.org/xfn/11">
		<link rel="pingback" href="https://themeshaper.com/xmlrpc.php">
		<script>(function(html){html.className = html.className.replace(/\bno-js\b/,'js')})(document.documentElement);</script>
<title>Getting Started with Block Themes: Templates &#8211; ThemeShaper</title>

<!-- Async WordPress.com Remote Login -->
<script id="wpcom_remote_login_js">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</script>
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//themeshaper.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="ThemeShaper &raquo; Feed" href="https://themeshaper.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="ThemeShaper &raquo; Comments Feed" href="https://themeshaper.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="ThemeShaper &raquo; Getting Started with Block Themes:&nbsp;Templates Comments Feed" href="https://themeshaper.com/2020/12/18/getting-started-with-block-themes-templates/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s2.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1605528427h&ver=5.6-RC5-49737"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJylkttOwzAMhl+I1OxUwQXiWXKwQracFDvq+vZkUUGoTGUSN1F+5/8sOzZMWegUGSNDqCL7al0kmLJOQVBwHueVGjTRE9zHdCoo+AMDUnsOWTLw1DwzuSsjxi22oJeMRuREvFJbmHcXJDgjZ6kvoqtf9i+vrU0qLFbcCoXX4TTsQVXnDSifOq6KLDMQzx7/n6b/xANpOvWjCTmnysIWZx6uZJWiSHbR0h+4Tgu2by0cwDji75i4j66HvUy5OQIaJ9G3jiNvYZMzFtuEm2W5C8brNtL3T6lckEi0M7galj27ce/hbTc+v+zG8Xg8nT8B+TEPfA==?cssminify=yes' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify {
	text-align:justify;
}
</style>
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='all-css-2-1' href='https://s0.wp.com/wp-content/themes/pub/twentysixteen/style.css?m=1548810130h&cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='themeshaper-fonts-css'  href='https://fonts.googleapis.com/css2?family=Overpass:wght@300;400;600;700;800&#038;display=swap' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='twentysixteen-fonts-css'  href='https://fonts.googleapis.com/css?family=Merriweather%3A400%2C700%2C900%2C400italic%2C700italic%2C900italic%7CMontserrat%3A400%2C700%7CInconsolata%3A400&#038;subset=latin%2Clatin-ext' media='all' />
<link rel='stylesheet' id='all-css-6-1' href='https://s2.wp.com/_static/??-eJx1jcEOgjAQRH9IXCGR4MH4LbBOoNpuG3Yb4O9piAcv3F5m5mVoSRVHMYhRyFXyeXSiNEIwu1Kc4JVVL/Tn2oQApb7jH059wvyOxjGQ2uZxpqQ8kC0l2NStBgiVIQ0+8ve4eYVn3d7uTfdom/qzA1rqQdw=?cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='twentysixteen-ie-css'  href='https://s2.wp.com/wp-content/themes/pub/twentysixteen/css/ie.css?m=1448353951h&#038;ver=20160816' media='all' />
<![endif]-->
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentysixteen-ie8-css'  href='https://s2.wp.com/wp-content/themes/pub/twentysixteen/css/ie8.css?m=1493067000h&#038;ver=20160816' media='all' />
<![endif]-->
<!--[if lt IE 8]>
<link rel='stylesheet' id='twentysixteen-ie7-css'  href='https://s2.wp.com/wp-content/themes/pub/twentysixteen/css/ie7.css?m=1448353951h&#038;ver=20160816' media='all' />
<![endif]-->
<link rel='stylesheet' id='all-css-12-1' href='https://s0.wp.com/_static/??-eJx9jUEOwjAMBD+EMRGtxAXxljYyISixo9pR2t+TcgEu3HZWGg22Al7YiA3tQZkUS53RWj82jasRMXpVVNsSQSte8rHzAb/EXKGkGiIrBhJI4ieLwj8A9zTF5Z+60Jwk9BnewQ/u0i1f3eiG8XR27vJ8AeH3Q6k=?cssminify=yes' type='text/css' media='all' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<link rel='stylesheet' id='all-css-14-1' href='https://s0.wp.com/_static/??-eJxti8sKgCAQAH8oW6KHdoi+xcTUWF1pjX4/OnSIOg0DM3BmYSgVmwrEQ2Q8XEgMmbiIFXXYgb3eQ3IPa8Ncwf/FZIJGgeToLZ+peBstg+/AIS0a72COU9OPUg69atV2AWWKN+I=?cssminify=yes' type='text/css' media='all' />
<script id='jetpack_related-posts-js-extra'>
var related_posts_js_options = {"post_heading":"h4"};
</script>
<script id='wpcom-actionbar-placeholder-js-extra'>
var actionbardata = {"siteID":"45531309","siteName":"ThemeShaper","siteURL":"https:\/\/themeshaper.com","icon":"<img alt='' src='https:\/\/secure.gravatar.com\/blavatar\/d444e67375d022ca42f4266011555f8c?s=50&d=https%3A%2F%2Fs2.wp.com%2Fi%2Flogo%2Fwpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"a8c\/themeshaperdotcom","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/wordpress.com\/log-in?redirect_to=https%3A%2F%2Fthemeshaper.com%2F2020%2F12%2F18%2Fgetting-started-with-block-themes-templates%2F&signup_flow=account&domain=themeshaper.com","themeURL":"","xhrURL":"https:\/\/themeshaper.com\/wp-admin\/admin-ajax.php","nonce":"37a39daba5","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"d161873696\" \/>","referer":"https:\/\/themeshaper.com\/2020\/12\/18\/getting-started-with-block-themes-templates\/","canFollow":"1","feedID":"7663","statusMessage":"","customizeLink":"https:\/\/themeshaper.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fthemeshaper.wordpress.com%2F2020%2F12%2F18%2Fgetting-started-with-block-themes-templates%2F","postID":"7642","shortlink":"https:\/\/wp.me\/p352LX-1Zg","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/themeshaper.com\/7642","statsLink":"https:\/\/wordpress.com\/stats\/post\/7642\/themeshaper.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: ThemeShaper","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/read\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 4,487 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/wordpress.com\/log-in?redirect_to=https%3A%2F%2Fthemeshaper.com%2F2020%2F12%2F18%2Fgetting-started-with-block-themes-templates%2F&signup_flow=account&domain=themeshaper.com\">Log in now.<\/a>","stats":"Stats"}};
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJxdjc0OgzAMg19oXYYQaBymPQs/AVq1adckYrz9ijQunCxbn23YkhkjCZKAYwhxsB6NMuZ+KZmxNMe74xsUztLodUI+QPdRzPtfTuAcCmqS18USQ0bfC04mRZaLu7ZkxVDGkw4gWwl2tl9BpONuleCbUniHV9U+nlXd1F3nfoGoRew='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1530132353h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://themeshaper.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://themeshaper.com/2020/12/18/getting-started-with-block-themes-templates/" />
<link rel='shortlink' href='https://wp.me/p352LX-1Zg' />
	<style>
		@font-face {
			font-family: Recoleta;
			src: url('https://s1.wp.com/i/fonts/recoleta/400.woff2')
		}
	</style>
	<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fthemeshaper.com%2F2020%2F12%2F18%2Fgetting-started-with-block-themes-templates%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fthemeshaper.com%2F2020%2F12%2F18%2Fgetting-started-with-block-themes-templates%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Getting Started with Block Themes: Templates" />
<meta property="og:url" content="https://themeshaper.com/2020/12/18/getting-started-with-block-themes-templates/" />
<meta property="og:description" content="Full Site Editing provides a new and exciting way to build themes, compared to how we created themes in the past. If you are new to this, there’s nothing to worry about, it’s simply a different way…" />
<meta property="article:published_time" content="2020-12-18T17:54:22+00:00" />
<meta property="article:modified_time" content="2020-12-18T20:58:44+00:00" />
<meta property="og:site_name" content="ThemeShaper" />
<meta property="og:image" content="https://themeshaper.files.wordpress.com/2020/12/overview-1.png?w=1200" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="617" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@ThemeShaper" />
<meta name="twitter:site" content="@ThemeShaper" />
<meta name="twitter:text:title" content="Getting Started with Block Themes:&nbsp;Templates" />
<meta name="twitter:image" content="https://themeshaper.files.wordpress.com/2020/12/overview-1.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<meta name="twitter:app:name:iphone" content="WordPress" />
<meta name="twitter:app:id:iphone" content="335703880" />
<meta name="twitter:app:name:ipad" content="WordPress" />
<meta name="twitter:app:id:ipad" content="335703880" />
<meta name="twitter:app:name:googleplay" content="WordPress" />
<meta name="twitter:app:id:googleplay" content="org.wordpress.android" />
<meta name="twitter:app:url:iphone" content="wordpress://viewpost?blogId=45531309&amp;postId=7642" />
<meta name="twitter:app:url:ipad" content="wordpress://viewpost?blogId=45531309&amp;postId=7642" />
<meta name="twitter:app:url:googleplay" content="wordpress://viewpost?blogId=45531309&amp;postId=7642" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/d444e67375d022ca42f4266011555f8c?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/d444e67375d022ca42f4266011555f8c?s=32" sizes="16x16" />
<link rel="apple-touch-icon" href="https://secure.gravatar.com/blavatar/d444e67375d022ca42f4266011555f8c?s=114" />
<link rel='openid.server' href='https://themeshaper.com/?openidserver=1' />
<link rel='openid.delegate' href='https://themeshaper.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://themeshaper.com/osd.xml" title="ThemeShaper" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<script type="text/javascript" id="webfont-output">
  
  WebFontConfig = {"typekit":{"id":"kwa3fql"}};
  (function() {
    var wf = document.createElement('script');
    wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
      '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
	})();
</script><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>		<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="ThemeShaper" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Shaping WordPress Themes" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://themeshaper.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/d444e67375d022ca42f4266011555f8c?s=16" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="description" content="Full Site Editing provides a new and exciting way to build themes, compared to how we created themes in the past. If you are new to this, there’s nothing to worry about, it’s simply a different way to create themes, leveraging the existing template hierarchy we all know and love. List of templates under Appearance&hellip;" />
<link rel="amphtml" href="https://themeshaper.com/2020/12/18/getting-started-with-block-themes-templates/amp/">		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s1.wp.com/?custom-css=1&#038;csblog=352LX&#038;cscache=6&#038;csrev=26" />
		<!-- Your Google Analytics Plugin is missing the tracking ID -->
</head>

<body class="post-template-default single single-post postid-7642 single-format-standard wp-embed-responsive customizer-styles-applied group-blog highlander-enabled highlander-light">
<div id="page" class="site">
	<div class="site-inner">
		<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

		<header id="masthead" class="site-header" role="banner">
			<div class="site-header-main">
				<div class="site-header-main--branding-menu">
					<div class="site-branding">

													<p class="screen-reader-text"><a href="https://themeshaper.com/" rel="home">ThemeShaper</a></p>
						
						<a class="site-logo" href="https://themeshaper.com/" rel="home">
							<svg version="1.1" class="themeshaper-logo" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
	 width="148px" height="57px" viewBox="0 0 148 57" style="enable-background:new 0 0 274.1 31.7;" fill="none" xml:space="preserve">
	<g clip-path="url(#clip0)">
	<path d="M11.9028 27.6345C16.853 27.6345 19.1335 24.817 19.1335 24.817L18.0272 21.1034C18.0272 21.1034 16.5069 23.8533 13.4602 23.8533C11.0005 23.8533 10.0673 22.4415 10.0673 20.109V11.4479H18.8924V8.1148H10.0735V0.92688L4.57324 4.36431V8.10866H0V11.4417H4.4311V20.5141C4.4311 25.437 7.26775 27.6345 11.9028 27.6345Z" fill="black"/>
	<path d="M58.3151 27.6345C68.2835 27.6345 69.7358 20.864 69.7358 20.864L64.1985 19.4522C64.1985 19.4522 64.1614 23.8533 58.9022 23.8533C54.2301 23.8533 52.4317 20.9315 52.3946 17.9729L69.2167 18.3227C69.7358 15.6096 69.1487 7.6667 58.3151 7.6667C51.1524 7.6667 46.6533 11.9635 46.6533 17.6353C46.6533 24.0989 52.1165 27.6345 58.3151 27.6345ZM58.21 11.276C62.8142 11.276 63.2962 14.9528 63.2962 14.9528L52.7407 15.2966C52.7407 15.2966 53.4328 11.276 58.21 11.276Z" fill="black"/>
	<path d="M88.0411 15.4009V27.1925H93.7515V15.6403C93.7515 15.6403 94.9257 11.4479 99.0787 11.4479C102.502 11.4479 102.886 13.5779 102.886 15.4009V27.1925H108.596V15.5053C108.596 10.2448 105.79 7.6667 100.945 7.6667C93.8504 7.6667 93.0531 12.9579 92.9852 13.4735C92.9852 13.2648 92.8492 7.6667 86.1006 7.6667C78.6227 7.6667 78.1407 13.5103 78.1407 13.5103L76.5153 8.1148H73.1904V27.1925H78.9008V15.6403C78.9008 15.6403 80.075 11.4479 84.228 11.4479C87.6641 11.4479 88.0411 13.5779 88.0411 15.4009Z" fill="black"/>
	<path d="M123.725 27.6345C133.693 27.6345 135.145 20.864 135.145 20.864L129.608 19.4522C129.608 19.4522 129.571 23.8533 124.312 23.8533C119.64 23.8533 117.841 20.9315 117.804 17.9729L134.626 18.3166C135.145 15.6035 134.558 7.66056 123.725 7.66056C116.562 7.66056 112.063 11.9574 112.063 17.6291C112.063 24.0989 117.526 27.6345 123.725 27.6345ZM123.62 11.276C128.224 11.276 128.706 14.9528 128.706 14.9528L118.15 15.2966C118.15 15.2966 118.843 11.276 123.62 11.276Z" fill="black"/>
	<path d="M19.8071 38.0266L14.9619 37.2348C12.7124 36.8542 11.291 36.5473 11.291 35.4117C11.291 34.448 12.3972 33.4168 14.8198 33.4168C19.7329 33.4168 19.906 36.7867 19.906 36.7867L25.4433 35.3749C25.4433 35.3749 24.6461 29.8074 15.0608 29.8074C10.0055 29.8074 5.99468 31.9743 5.99468 35.7554C5.99468 39.2297 9.41843 40.396 12.4652 40.9484L16.9643 41.7709C19.665 42.2497 20.8392 42.839 20.8392 44.0053C20.8392 45.3434 18.8677 46.0002 16.5811 46.0002C10.5247 46.0002 10.5617 41.7034 10.5617 41.7034L5.02441 43.1152C5.02441 43.1152 5.47556 49.7814 16.5131 49.7814C22.0505 49.7814 26.4816 47.7189 26.4816 43.8334C26.4877 41.0159 24.6523 38.8184 19.8071 38.0266Z" fill="black"/>
	<path d="M42.4755 29.8136C36.005 29.8136 35.0348 34.491 34.9668 34.9329V28.8867V28.9235C34.9668 26.2166 33.7122 24.7863 32.0992 24.0866C31.2093 23.6999 30.2143 23.5403 29.2564 23.5157C28.4159 23.4973 27.6001 23.5771 26.9265 23.7121H26.9203V21.797V20.4527H26.9265V15.6342C26.9265 15.6342 27.9277 11.4417 32.8779 11.4417C35.5786 11.4417 37.513 12.6817 37.513 15.2229V27.1925H43.1862V15.5053C43.1862 10.656 40.3805 7.6667 34.4291 7.6667C27.9586 7.6667 26.9883 12.3441 26.9203 12.786V0C26.9203 0 24.3618 0.478785 21.21 0.478785V27.1925H23.3483C26.018 27.2355 29.2008 27.6284 29.2502 30.4642V49.3394H34.9606V37.7872C34.9606 37.7872 35.9618 33.5948 40.912 33.5948C43.6127 33.5948 45.547 34.8347 45.547 37.3759V49.3394H51.2203V37.6522C51.2327 32.8029 48.4331 29.8136 42.4755 29.8136Z" fill="black"/>
	<path d="M75.6316 46.0002C74.5934 46.0002 74.2102 45.1777 74.2473 44.1096L74.5563 36.9954C74.6923 33.1098 71.4045 29.8136 65.175 29.8136C55.4846 29.8136 53.6492 36.3079 53.6492 36.3079L59.6006 37.8179C59.6006 37.8179 59.6376 33.5886 64.8969 33.5886C68.4257 33.5886 68.8397 35.7186 68.8397 37.4742C58.3213 38.3703 54.5453 42.0472 54.5453 45.2452C54.5453 48.1302 56.6898 49.7814 60.2186 49.7814C66.17 49.7814 69.4269 43.6308 69.5999 43.3178C69.5999 47.1665 70.6381 49.7814 74.7541 49.7814C77.7638 49.7814 79.3582 47.9952 79.3582 47.9952L78.2149 44.2815C78.2273 44.2815 77.2261 46.0002 75.6316 46.0002ZM68.8521 40.6415C68.8521 40.6415 66.5346 46.0064 62.5176 46.0064C60.7871 46.0064 60.509 44.9076 60.509 44.0789C60.509 42.2559 62.5485 39.8865 68.8521 39.3034V40.6415Z" fill="black"/>
	<path d="M93.2817 29.8136C87.0893 29.8136 85.3898 34.626 85.3898 34.626L84.0734 30.2617H80.7485V57.0061H86.4589V46.2764C86.4589 46.2764 87.9483 49.7814 93.3126 49.7814C99.128 49.7814 103.417 45.6196 103.417 39.776C103.423 33.9385 99.128 29.8136 93.2817 29.8136ZM91.4462 46.0002C87.2561 46.0002 85.5628 42.9434 85.5628 39.776C85.5628 36.6148 87.2561 33.5886 91.4462 33.5886C95.5621 33.5886 97.4347 36.3017 97.4347 39.776C97.4347 43.2503 95.5683 46.0002 91.4462 46.0002Z" fill="black"/>
	<path d="M118.095 46.0002C113.423 46.0002 111.624 43.0784 111.587 40.1197L128.409 40.4635C128.928 37.7504 128.341 29.8074 117.508 29.8074C110.345 29.8074 105.846 34.1042 105.846 39.776C105.846 46.2396 111.315 49.7814 117.508 49.7814C127.476 49.7814 128.928 43.0109 128.928 43.0109L123.391 41.5991C123.391 41.6052 123.36 46.0002 118.095 46.0002ZM117.403 33.4229C122.007 33.4229 122.489 37.0997 122.489 37.0997L111.933 37.4435C111.933 37.4435 112.632 33.4229 117.403 33.4229Z" fill="black"/>
	<path d="M142.84 29.8136C137.265 29.8136 137.339 35.6572 137.339 35.6572L135.714 30.2617H132.389V49.3394H138.1V37.7504C138.1 37.7504 138.656 33.5886 141.078 33.5886C141.733 33.5886 142.599 33.8955 142.599 35.3073C142.599 37.9223 142.012 39.8435 142.012 39.8435L147.549 38.4317C147.549 38.4317 148 37.1611 148 34.7856C148 32.1154 146.82 29.8136 142.84 29.8136Z" fill="black"/>
	</g>
	<defs>
	<clipPath id="clip0">
	<rect width="148" height="57" fill="white"/>
	</clipPath>
	</defs>
</svg>

						</a>

													<p class="site-description">Shaping WordPress Themes</p>
											</div><!-- .site-branding -->

											<button id="menu-toggle" class="menu-toggle">Menu</button>

						<div id="site-header-menu" class="site-header-menu">
															<nav id="site-navigation" class="main-navigation" role="navigation" aria-label="Primary Menu">
									<div class="menu-main-container"><ul id="menu-main" class="primary-menu"><li id="menu-item-4983" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4983"><a href="https://themeshaper.com/about/">About</a></li>
<li id="menu-item-4973" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4973"><a href="https://themeshaper.com/contact/">Contact</a></li>
<li id="menu-item-7431" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7431"><a href="https://twitter.com/themeshaper">Twitter</a></li>
</ul></div>								</nav><!-- .main-navigation -->
							
													</div><!-- .site-header-menu -->
									</div>
				
<form role="search" method="get" class="search-form" action="https://themeshaper.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
	</label>
	<button type="submit" class="search-submit"><span class="screen-reader-text">Search</span></button>
</form>
				<hr>
			</div><!-- .site-header-main -->
		</header><!-- .site-header -->

		<div id="content" class="site-content">


<div id="primary" class="content-area">
	<main id="main" class="site-main" role="main">
		
<article id="post-7642" class="post-7642 post type-post status-publish format-standard has-post-thumbnail hentry category-theme-development">
	<header class="entry-header">
		<h1 class="entry-title">Getting Started with Block Themes:&nbsp;Templates</h1>	</header><!-- .entry-header -->

	
	
		<div class="post-thumbnail">
			<img width="1200" height="617" src="https://themeshaper.files.wordpress.com/2020/12/overview-1.png?w=1200" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" srcset="https://themeshaper.files.wordpress.com/2020/12/overview-1.png?w=1200 1200w, https://themeshaper.files.wordpress.com/2020/12/overview-1.png?w=2400 2400w, https://themeshaper.files.wordpress.com/2020/12/overview-1.png?w=150 150w, https://themeshaper.files.wordpress.com/2020/12/overview-1.png?w=300 300w, https://themeshaper.files.wordpress.com/2020/12/overview-1.png?w=768 768w, https://themeshaper.files.wordpress.com/2020/12/overview-1.png?w=1024 1024w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 60vw, (max-width: 1362px) 62vw, 840px" data-attachment-id="7673" data-permalink="https://themeshaper.com/2020/12/18/getting-started-with-block-themes-templates/overview-2/" data-orig-file="https://themeshaper.files.wordpress.com/2020/12/overview-1.png" data-orig-size="2800,1440" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Overview" data-image-description="" data-medium-file="https://themeshaper.files.wordpress.com/2020/12/overview-1.png?w=300" data-large-file="https://themeshaper.files.wordpress.com/2020/12/overview-1.png?w=840" />	</div><!-- .post-thumbnail -->

	
	<div class="entry-content">
		
<p>Full Site Editing provides a new and exciting way to build themes, compared to how we created themes in the past. If you are new to this, there’s nothing to worry about, it’s simply a different way to create themes, leveraging the existing <a href="https://developer.wordpress.org/themes/basics/template-hierarchy/">template hierarchy</a> we all know and love.</p>



<div class="wp-block-group"><div class="wp-block-group__inner-container">
<figure class="wp-block-image size-large"><img data-attachment-id="7644" data-permalink="https://themeshaper.com/screen-shot-2020-12-18-at-12-04-27-pm/" data-orig-file="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.04.27-pm.png" data-orig-size="1225,837" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="screen-shot-2020-12-18-at-12.04.27-pm" data-image-description="" data-medium-file="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.04.27-pm.png?w=300" data-large-file="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.04.27-pm.png?w=840" src="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.04.27-pm.png?w=840" alt="" class="wp-image-7644" srcset="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.04.27-pm.png?w=840 840w, https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.04.27-pm.png?w=150 150w, https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.04.27-pm.png?w=300 300w, https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.04.27-pm.png?w=768 768w, https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.04.27-pm.png?w=1024 1024w, https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.04.27-pm.png 1225w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 62vw, 840px" /><figcaption>List of templates under Appearance » Themes.</figcaption></figure>
</div></div>



<p>A block-based theme can be customized from the Site Editor by making use of templates and template parts. A <strong>template</strong> is analogous to a <a href="https://developer.wordpress.org/themes/basics/template-files/">template file</a> in WordPress, following the same naming convention from the template hierarchy. You can edit templates from the Site Editor, or in the Block Editor under Appearance » Templates.</p>



<p>A template can contain individual blocks, or it can use reusable structural <strong>template parts</strong>, such as header, footer, and sidebar, for example. Template parts are not limited to the common reusable areas of a site, they can be virtually anything: a contact form, a call to action banner, or anything you want it to be.</p>



<p><em>When you update a template part from within a template, the template part is automatically updated everywhere (on all templates that use it). This works in the same way as reusable blocks, streamlining the process of working with templates.</em></p>



<p>The complexity of your theme will determine how many templates you need to create. You have freedom to use the Site Editor in any way you like, but for most themes you’ll want to create some template parts.&nbsp;</p>



<p>Templates live in the theme code, inside the <strong>block-templates/</strong> directory, as individual HTML files. Template Parts are stored in the <strong>block-template-parts/</strong> directory.&nbsp; Both templates and template parts are automatically loaded when WordPress loads, and are readily available in the Site Editor and Block Editor.</p>



<figure class="wp-block-image size-large"><img data-attachment-id="7646" data-permalink="https://themeshaper.com/screen-shot-2020-12-18-at-11-59-03-am/" data-orig-file="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-11.59.03-am.png" data-orig-size="1083,875" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="screen-shot-2020-12-18-at-11.59.03-am" data-image-description="" data-medium-file="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-11.59.03-am.png?w=300" data-large-file="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-11.59.03-am.png?w=840" src="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-11.59.03-am.png?w=1024" alt="" class="wp-image-7646" srcset="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-11.59.03-am.png?w=1024 1024w, https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-11.59.03-am.png?w=150 150w, https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-11.59.03-am.png?w=300 300w, https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-11.59.03-am.png?w=768 768w, https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-11.59.03-am.png 1083w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 62vw, 840px" /><figcaption>Source code of a template HTML file.</figcaption></figure>



<p>Templates and template parts can be stored as data, just like posts or pages. You can save a template and design your site’s behavior directly from the Site Editor, without having to provide the template HTML file in the first place.</p>



<h3>Block templates</h3>



<p>In the classic way of theming, we usually have functions that give us the different parts that make up a post, such as <code>the_title()</code>, <code>the_content()</code>, and so on. Block themes give us the same features using blocks directly!</p>



<p>For this purpose, some blocks have been made to be used with block-based themes. For example, you&#8217;ll most likely use the <strong>Site Title</strong> block in your site&#8217;s header while your single post template will most likely include a <strong>Post Title</strong> and a <strong>Post Content</strong> block.</p>



<p>As we&#8217;re still early in the process, the number of blocks is relatively small, but more will be added as the project evolves. For more information on this, you can refer to the official <a href="https://github.com/WordPress/gutenberg/blob/master/docs/designers-developers/developers/themes/block-based-themes.md#theme-blocks">block themes reference</a>.</p>



<p>When you build your template there are some important blocks you’ll want to use, which are covered in the sections below.</p>



<h3>Site Level blocks</h3>



<p>These blocks will be the same on every page &#8211; they get their content from the database. If you change the Site Title in this block, it updates everywhere on the site:</p>



<div class="wp-block-group"><div class="wp-block-group__inner-container">
<ul><li>Site Title</li><li>Site Tagline</li><li>Site Logo</li></ul>
</div></div>



<h3>Navigation</h3>



<p>Navigation is one of the most important parts of a website. The navigation block allows you to select menus you have previously created, or create new ones directly from the Site Editor.</p>



<p>If you have a header template part, this is a good place to add the Navigation block.</p>



<figure class="wp-block-image size-large"><img data-attachment-id="7647" data-permalink="https://themeshaper.com/screen-shot-2020-12-18-at-12-02-39-pm/" data-orig-file="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.02.39-pm.png" data-orig-size="940,490" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="screen-shot-2020-12-18-at-12.02.39-pm" data-image-description="" data-medium-file="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.02.39-pm.png?w=300" data-large-file="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.02.39-pm.png?w=840" src="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.02.39-pm.png?w=940" alt="" class="wp-image-7647" srcset="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.02.39-pm.png 940w, https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.02.39-pm.png?w=150 150w, https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.02.39-pm.png?w=300 300w, https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.02.39-pm.png?w=768 768w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 62vw, 840px" /><figcaption>The navigation block in use.</figcaption></figure>



<h3>Query block</h3>



<p>The Query Block is different from other blocks; its content changes depending on the context in which it’s used.&nbsp;</p>



<p>On the front page, the Query block will show your latest posts (by default). On an archive / category / tag page, the block will show the relevant content for that page.&nbsp;</p>



<p>There are several blocks you can add inside the Query Block:</p>



<div class="wp-block-group"><div class="wp-block-group__inner-container">
<ul><li>Post Title</li><li>Post Content</li><li>Post author</li><li>Post Comments</li><li>Post Comments Count</li><li>Post Comments Form</li><li>Post Date</li><li>Post Excerpt</li></ul>
</div></div>



<p>You can combine these dynamic blocks with other blocks, for example columns, to change the layout of your posts and pages to your liking.</p>



<p><em>Dynamic blocks are blocks that use placeholders in the Site Editor, but will actually read information from the database when the blocks are rendered into the page. Therefore, it’s completely normal to not see the actual content when you are editing or inserting the block,&nbsp; it will appear when the block is properly rendered.</em></p>



<h3>Saving templates</h3>



<p>After you have created all the templates and template parts in the Site Editor, you can save your templates to their corresponding HTML files. These can then be included in the theme.</p>



<p>Templates can be exported from the Site Editor, by clicking on the three dots button on the top-right hand side, and then clicking on Export.</p>



<figure class="wp-block-image size-large"><img data-attachment-id="7650" data-permalink="https://themeshaper.com/screen-shot-2020-12-18-at-12-10-16-pm/" data-orig-file="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.10.16-pm.png" data-orig-size="1241,860" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="screen-shot-2020-12-18-at-12.10.16-pm" data-image-description="" data-medium-file="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.10.16-pm.png?w=300" data-large-file="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.10.16-pm.png?w=840" src="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.10.16-pm.png?w=1024" alt="" class="wp-image-7650" srcset="https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.10.16-pm.png?w=1024 1024w, https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.10.16-pm.png?w=150 150w, https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.10.16-pm.png?w=300 300w, https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.10.16-pm.png?w=768 768w, https://themeshaper.files.wordpress.com/2020/12/screen-shot-2020-12-18-at-12.10.16-pm.png 1241w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 62vw, 840px" /><figcaption>Exporting a template from the Site Editor.</figcaption></figure>



<p>After exporting, you get a ZIP file downloaded to your computer, with all templates and template parts. You can extract the ZIP archive and copy the <strong>block-templates/</strong> and <strong>block-template-parts/</strong> directories into your theme and you’re good to go!</p>



<p>When the template files are bundled with the theme, they will automatically be loaded when WordPress starts. There is no need to import or create the templates, they are loaded directly!</p>



<h3>Template loading order</h3>



<p>As mentioned above, if a template is saved into the theme code, it will be automatically loaded on startup. You can make edits to the template from the Site Editor.&nbsp;</p>



<p>Once the template is saved in the Site Editor, the template file will no longer be used. This means that changes saved from the Site Editor take precedence over the content stored in the template HTML files.</p>



<p>Have in mind, that if you make edits to any of the templates provided by the theme, the template you saved with your changes will be used instead of the template on disk. This means, if the theme ships an updated version of the template, you will not be able to see the changes unless you delete the templates from Appearance » Templates.</p>



<p>Up next, we’ll be talking about Global Styles, stay tuned!</p>
<div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-7642" class="share-twitter sd-button share-icon" href="https://themeshaper.com/2020/12/18/getting-started-with-block-themes-templates/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-7642" class="share-facebook sd-button share-icon" href="https://themeshaper.com/2020/12/18/getting-started-with-block-themes-templates/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://themeshaper.com/2020/12/18/getting-started-with-block-themes-templates/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-7642" class="share-linkedin sd-button share-icon" href="https://themeshaper.com/2020/12/18/getting-started-with-block-themes-templates/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-end"></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-7642" class="share-pinterest sd-button share-icon" href="https://themeshaper.com/2020/12/18/getting-started-with-block-themes-templates/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://themeshaper.com/2020/12/18/getting-started-with-block-themes-templates/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-end"></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://themeshaper.com/2020/12/18/getting-started-with-block-themes-templates/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://themeshaper.com/2020/12/18/getting-started-with-block-themes-templates/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-end"></li><li class="share-skype"><a rel="nofollow noopener noreferrer" data-shared="sharing-skype-7642" class="share-skype sd-button share-icon" href="https://themeshaper.com/2020/12/18/getting-started-with-block-themes-templates/?share=skype" target="_blank" title="Click to share on Skype"><span>Skype</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon" href="https://themeshaper.com/2020/12/18/getting-started-with-block-themes-templates/?share=telegram" target="_blank" title="Click to share on Telegram"><span>Telegram</span></a></li><li class="share-end"></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon" href="https://themeshaper.com/2020/12/18/getting-started-with-block-themes-templates/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="https://themeshaper.com/2020/12/18/getting-started-with-block-themes-templates/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-45531309-7642-5fe3c9826fa99' data-src='//widgets.wp.com/likes/index.html?ver=20200826#blog_id=45531309&amp;post_id=7642&amp;origin=themeshaper.wordpress.com&amp;obj_id=45531309-7642-5fe3c9826fa99&amp;domain=themeshaper.com' data-name='like-post-frame-45531309-7642-5fe3c9826fa99'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>
<div class="author-info">
	<div class="author-avatar">
		<img alt='' src='https://1.gravatar.com/avatar/7db2169ac3e92d0c23ca5615eb283642?s=42&#038;d=identicon&#038;r=G' class='avatar avatar-42' height='42' width='42' />	</div><!-- .author-avatar -->

	<div class="author-description">
		<h2 class="author-title"><span class="author-heading">Author:</span> Ernesto Méndez</h2>

		<p class="author-bio">
			Theme Generator | Automattic			<a class="author-link" href="https://themeshaper.com/author/mendezcode/" rel="author">
				View all posts by Ernesto Méndez			</a>
		</p><!-- .author-bio -->
	</div><!-- .author-description -->
</div><!-- .author-info -->
	</div><!-- .entry-content -->

	<footer class="entry-footer">
		<span class="byline"><span class="author vcard"><img alt='' src='https://1.gravatar.com/avatar/7db2169ac3e92d0c23ca5615eb283642?s=49&#038;d=identicon&#038;r=G' class='avatar avatar-49' height='49' width='49' /><span>by </span> <a class="url fn n" href="https://themeshaper.com/author/mendezcode/">Ernesto Méndez</a></span></span><span class="posted-on"><span class="screen-reader-text">Posted on </span><a href="https://themeshaper.com/2020/12/18/getting-started-with-block-themes-templates/" rel="bookmark"><time class="entry-date published" datetime="2020-12-18T17:54:22+00:00">December 18, 2020</time><time class="updated" datetime="2020-12-18T20:58:44+00:00">December 18, 2020</time></a></span><span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://themeshaper.com/category/theme-development/" rel="category tag">Theme Development</a></span>			</footer><!-- .entry-footer -->
</article><!-- #post-## -->

<div id="comments" class="comments-area">

	
	
		<div id="respond" class="comment-respond">
		<h2 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/12/18/getting-started-with-block-themes-templates/#respond" style="display:none;">Cancel reply</a></small></h2><form action="https://themeshaper.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="6c903ecc75" /><input type="hidden" name="_wp_http_referer" value="/2020/12/18/getting-started-with-block-themes-templates/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">
	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" class="nascar-signin-link"
                   title="Login via Guest">
									</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" class="nascar-signin-link"
                   title="Login via WordPress.com">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" class="nascar-signin-link"
                   title="Login via Twitter">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" class="nascar-signin-link"
                   title="Login via Facebook">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg>				</a>
			</li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
			
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
						<p class="comment-form-posting-as pa-wordpress">
			<strong></strong>
			You are commenting using your WordPress.com account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Google photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
						<p class="comment-form-posting-as pa-googleplus">
			<strong></strong>
			You are commenting using your Google account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" x="0px" y="0px" viewBox="0 0 60 60" ><path fill="#519bf7" d="M56.3,30c0,-1.6 -0.2,-3.4 -0.6,-5h-3.1H42.2H30v10.6h14.8C44,39.3 42,42 39.1,43.9l8.8,6.8C53,46 56.3,39 56.3,30z" /><path fill="#3db366" d="M30,57.5c6.7,0 13.1,-2.4 17.9,-6.8l-8.8,-6.8c-2.5,1.6 -5.6,2.4 -9.1,2.4c-7.2,0 -13.3,-4.7 -15.4,-11.2l-9.3,7.1C9.8,51.3 19.1,57.5 30,57.5z" /><path fill="#fdc600" d="M5.3,42.2l9.3,-7.1c-0.5,-1.6 -0.8,-3.3 -0.8,-5.1s0.3,-3.5 0.8,-5.1l-9.3,-7.1C3.5,21.5 2.5,25.6 2.5,30S3.5,38.5 5.3,42.2z" /><path fill="#f15b44" d="M40.1,17.4l8,-8C43.3,5.1 37,2.5 30,2.5C19.1,2.5 9.8,8.7 5.3,17.8l9.3,7.1c2.1,-6.5 8.2,-11.1 15.4,-11.1C33.9,13.7 37.4,15.1 40.1,17.4z" /></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
						<p class="comment-form-posting-as pa-twitter">
			<strong></strong>
			You are commenting using your Twitter account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
						<p class="comment-form-posting-as pa-facebook">
			<strong></strong>
			You are commenting using your Facebook account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='7642' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="70a8d64c5b" /></p>
<input type="hidden" name="genseq" value="1608763778" />
<input type="hidden" id="ak_js" name="ak_js" value="19"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	<div style="clear: both"></div>
</div><!-- .comments-area -->

	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://themeshaper.com/2020/12/09/getting-started-with-block-themes/" rel="prev"><span class="meta-nav" aria-hidden="true">Previous</span> <span class="screen-reader-text">Previous post:</span> <span class="post-title">Getting Started with Block&nbsp;Themes</span></a></div></div>
	</nav>
	</main><!-- .site-main -->

</div><!-- .content-area -->


		</div><!-- .site-content -->
	</div><!-- .site-inner -->
</div><!-- .site -->

<aside id="content-bottom-widgets" class="content-bottom-widgets" role="complementary">
			<div class="widget-area">
			<section id="categories-2" class="widget widget_categories"><h2 class="widget-title">Topics</h2>
			<ul>
					<li class="cat-item cat-item-4624"><a href="https://themeshaper.com/category/asides/">Asides</a>
</li>
	<li class="cat-item cat-item-2528"><a href="https://themeshaper.com/category/community/">Community</a>
</li>
	<li class="cat-item cat-item-797338"><a href="https://themeshaper.com/category/css-tips/">CSS Tips</a>
</li>
	<li class="cat-item cat-item-148"><a href="https://themeshaper.com/category/design/">Design</a>
</li>
	<li class="cat-item cat-item-1342"><a href="https://themeshaper.com/category/education/">Education</a>
</li>
	<li class="cat-item cat-item-374"><a href="https://themeshaper.com/category/ideas/">Ideas</a>
</li>
	<li class="cat-item cat-item-497"><a href="https://themeshaper.com/category/site-news/">Site News</a>
</li>
	<li class="cat-item cat-item-154839207"><a href="https://themeshaper.com/category/thematic-child-themes/">Thematic Child Themes</a>
</li>
	<li class="cat-item cat-item-7627137"><a href="https://themeshaper.com/category/theme-development/">Theme Development</a>
</li>
	<li class="cat-item cat-item-335977820"><a href="https://themeshaper.com/category/theme-launches/">Theme Launches</a>
</li>
	<li class="cat-item cat-item-30671217"><a href="https://themeshaper.com/category/theme-team/">Theme Team</a>
</li>
	<li class="cat-item cat-item-79130688"><a href="https://themeshaper.com/category/theme-testing/">Theme Testing</a>
</li>
	<li class="cat-item cat-item-5230872"><a href="https://themeshaper.com/category/theme-tips/">Theme Tips</a>
</li>
	<li class="cat-item cat-item-540"><a href="https://themeshaper.com/category/themes/">Themes</a>
</li>
	<li class="cat-item cat-item-1981"><a href="https://themeshaper.com/category/tools/">Tools</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://themeshaper.com/category/uncategorized/">Uncategorized</a>
</li>
			</ul>

			</section>		</div><!-- .widget-area -->
	
			<div class="widget-area">
			<section id="search-4" class="widget widget_search"><h2 class="widget-title">Search</h2>
<form role="search" method="get" class="search-form" action="https://themeshaper.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
	</label>
	<button type="submit" class="search-submit"><span class="screen-reader-text">Search</span></button>
</form>
</section><section id="text-8" class="widget widget_text"><h2 class="widget-title">About</h2>			<div class="textwidget"><p>This is ThemeShaper, a WordPress-powered blog and home to the <a href="https://automattic.com/">Automattic</a> Theme Division. We shape beautiful and customizable themes that make the world a better place.</p>
</div>
		</section>		</div><!-- .widget-area -->
	</aside><!-- .content-bottom-widgets -->

<footer id="colophon" class="site-footer" role="contentinfo">
			<nav class="main-navigation" role="navigation" aria-label="Footer Primary Menu">
			<div class="menu-main-container"><ul id="menu-main-1" class="primary-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4983"><a href="https://themeshaper.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4973"><a href="https://themeshaper.com/contact/">Contact</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7431"><a href="https://twitter.com/themeshaper">Twitter</a></li>
</ul></div>		</nav><!-- .main-navigation -->
	
	
	<div class="site-info">
		<div class="site-info-text">
			Theme: Twenty Sixteen.			<span class="site-title"><a href="https://themeshaper.com/" rel="home">ThemeShaper</a></span>
			<a href="https://wordpress.com/?ref=footer_blog" rel="nofollow">Blog at WordPress.com.</a>
		</div><!-- .site-info-text -->

		<a class="site-info-logo" href="http://www.automattic.com">
			<span class="screen-reader-text">Automattic</span>
			<svg version="1.1" class="automattic-logo" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="494.4px" height="38.2px" viewBox="0 0 494.4 38.2" style="enable-background:new 0 0 494.4 38.2;" xml:space="preserve">
<g>
	<path class="automattic-o" d="M179.3,38.2c-12.6,0-20.7-9.1-20.7-18.5v-1.2c0-9.6,8.2-18.5,20.7-18.5c12.6,0,20.8,8.9,20.8,18.5v1.2C200.1,29.1,191.9,38.2,179.3,38.2z M193.3,18.6c0-6.9-5-13-14.1-13c-9.1,0-14,6.1-14,13v0.9c0,6.9,5,13.1,14,13.1c9.1,0,14.1-6.2,14.1-13.1V18.6z"/>
	<path d="M37.1,36.8L32.4,28H11.6L7,36.8H0L19.2,1.3h5.5l19.5,35.5H37.1z M21.8,8.2l-7.7,14.9h15.7L21.8,8.2z"/>
	<path d="M74.6,38.2c-12.7,0-18.7-6.9-18.7-16.2V1.3h6.6v20.9c0,6.6,4.3,10.5,12.5,10.5c8.4,0,11.9-3.9,11.9-10.5V1.3h6.7V22C93.6,30.8,87.9,38.2,74.6,38.2z"/>
	<path d="M130.7,6.8v30h-6.7v-30h-15.5V1.3h37.7v5.5H130.7z"/>
	<path d="M259.5,36.8V8.7l-1.8,3.1l-14.9,25h-3.3l-14.7-25l-1.8-3.1v28.1h-6.5V1.3h9.2l14,24.4l1.7,3l1.7-3L257,1.3h9.1v35.5H259.5z"/>
	<path d="M316.5,36.8l-4.7-8.8H291l-4.5,8.8h-7l19.2-35.5h5.5l19.5,35.5H316.5z M301.2,8.2l-7.7,14.9h15.7L301.2,8.2z"/>
	<path d="M350.6,6.8v30h-6.7v-30h-15.5V1.3h37.7v5.5H350.6z"/>
	<path d="M399.5,6.8v30h-6.7v-30h-15.5V1.3H415v5.5H399.5z"/>
	<path d="M431.4,36.8V4.6c2.7,0,3.7-1.4,3.7-3.4h2.8v35.5H431.4z"/>
	<path d="M490.2,11.3c-3.2-2.9-7.9-5.7-14.2-5.7c-9.5,0-14.8,6.5-14.8,13.3v0.7c0,6.7,5.4,13,15.3,13c5.9,0,10.8-2.8,13.9-5.7l4,4.2c-3.9,3.8-10.5,7.1-18.3,7.1c-13.4,0-21.6-8.7-21.6-18.3v-1.2c0-9.6,8.9-18.7,21.9-18.7c7.5,0,14.3,3.1,18,7.1L490.2,11.3z"/>
	<path d="M183.6,12.4c1.2,0.8,1.5,2.4,0.8,3.6l-6.1,9.4c-0.8,1.2-2.4,1.6-3.6,0.8l0,0c-1.2-0.8-1.5-2.4-0.8-3.6l6.1-9.4C180.8,11.9,182.4,11.6,183.6,12.4L183.6,12.4z"/>
</g>
</svg>
		</a>
	</div><!-- .site-info -->
</footer><!-- .site-footer -->

<!--  -->
<script src='//0.gravatar.com/js/gprofiles.js?ver=202052y' id='grofiles-cards-js'></script>
<script id='wpgroho-js-extra'>
var WPGroHo = {"my_hash":""};
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	<div class="grofile-hash-map-7db2169ac3e92d0c23ca5615eb283642">
	</div>
	</div>
<script id='highlander-comments-js-extra'>
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/themeshaper.wordpress.com\/public.api\/connect\/?action=request&domain=themeshaper.com","logoutURL":"https:\/\/themeshaper.wordpress.com\/wp-login.php?action=logout&_wpnonce=bdae8526de","homeURL":"https:\/\/themeshaper.com\/","postID":"7642","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1573483029j'></script>

<script>
window.addEventListener( "load", function( event ) {
	var link = document.createElement( "link" );
	link.href = "https://s0.wp.com/wp-content/mu-plugins/actionbar/actionbar.css?v=20201002";
	link.type = "text/css";
	link.rel = "stylesheet";
	document.head.appendChild( link );

	var script = document.createElement( "script" );
	script.src = "https://s0.wp.com/wp-content/mu-plugins/actionbar/actionbar.js?v=20201002";
	script.defer = true;
	document.body.appendChild( script );
} );
</script>

	
	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<label for="carousel-reblog-content" id="carousel-reblog-lblogcontent" class="screen-reader-text">Add your thoughts here... (optional)</label>
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="45531309" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://themeshaper.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="ThemeShaper" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="dc867f11b5" /><input type="hidden" name="_wp_http_referer" value="/2020/12/18/getting-started-with-block-themes-templates/" />		</form>

		<div class="arrow"></div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/themeshaper.com\/2020\/12\/18\/getting-started-with-block-themes-templates\/":7642};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/2020/12/18/getting-started-with-block-themes-templates/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<div
				class="g-recaptcha"
				data-sitekey="6LcmyE0UAAAAALID28yVNg7pFCodGaArJzHitez_"
				data-theme="light"
				data-type="image"
				data-tabindex="0"></div>
			<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en" async></script>
			
			<img style="float: right; display: none" class="loading" src="https://s2.wp.com/wp-content/mu-plugins/post-flair/sharing/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<link rel='stylesheet' id='all-css-0-3' href='https://s0.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1592560282h&cssminify=yes' type='text/css' media='all' />
<script id='twentysixteen-script-js-extra'>
var screenReaderText = {"expand":"expand child menu","collapse":"collapse child menu"};
</script>
<script id='jetpack-carousel-js-extra'>
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/themeshaper.com\/wp-admin\/admin-ajax.php","nonce":"9f2a4c5e11","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/themeshaper.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fthemeshaper.com%2F2020%2F12%2F18%2Fgetting-started-with-block-themes-templates%2F","blog_id":"45531309","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=45531309&v=wpcom&tz=0&user_id=0&subd=themeshaper","is_public":"1","reblog_enabled":""};
</script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyVkt1OwzAMhV+IxBvbKm4Qj4LS1G3d/BIn68rTk00UCYaKuHJkn89HxwrMUejgM/oME0OHZ9IYL3LiB/g+ioGzQ2Y14C/T6a1gWj6LJH8mnP+UTZij0kYkZHq/2+qKiLYM5BksGWSoUMFR+c5i+ilelTq0NmjD8ChP8gAd8c13bQtLw5jbcBcwj1jDQSwt5Lk2FqZLRvRXmA3FCnoj+qALi56+cPLalq6CNw/nKlnTRLtIR/4/Hn3xOlPwvHEF1dWlolUJnOKMqb5ETvWAW5BWKRRGC+ux18aWkSF2mMVB7uC1RoQ+JLehv34N0VtFCXhUifyw1gq9uOd9s3vaN83xeJo+AHEE6V0='></script>
<script type='text/javascript'>
var windowOpen;
			document.body.addEventListener( 'click', function ( event ) {
				if ( event.target &&
						( event.target.matches && event.target.matches( 'a.share-twitter' ) ) ||
						( event.target.msMatchesSelector && event.target.msMatchesSelector( 'a.share-twitter' ) ) ) {
					// If there's another sharing window open, close it.
					if ( typeof windowOpen !== 'undefined' ) {
						windowOpen.close();
					}
					windowOpen = window.open( event.target.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
					return false;
				}
			} );
var windowOpen;
			document.body.addEventListener( 'click', function ( event ) {
				if ( event.target &&
						( event.target.matches && event.target.matches( 'a.share-facebook' ) ) ||
						( event.target.msMatchesSelector && event.target.msMatchesSelector( 'a.share-facebook' ) ) ) {
					// If there's another sharing window open, close it.
					if ( typeof windowOpen !== 'undefined' ) {
						windowOpen.close();
					}
					windowOpen = window.open( event.target.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
					return false;
				}
			} );
var windowOpen;
			document.body.addEventListener( 'click', function ( event ) {
				if ( event.target &&
						( event.target.matches && event.target.matches( 'a.share-linkedin' ) ) ||
						( event.target.msMatchesSelector && event.target.msMatchesSelector( 'a.share-linkedin' ) ) ) {
					// If there's another sharing window open, close it.
					if ( typeof windowOpen !== 'undefined' ) {
						windowOpen.close();
					}
					windowOpen = window.open( event.target.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
					return false;
				}
			} );
var windowOpen;
			document.body.addEventListener( 'click', function ( event ) {
				if ( event.target &&
						( event.target.matches && event.target.matches( 'a.share-pocket' ) ) ||
						( event.target.msMatchesSelector && event.target.msMatchesSelector( 'a.share-pocket' ) ) ) {
					// If there's another sharing window open, close it.
					if ( typeof windowOpen !== 'undefined' ) {
						windowOpen.close();
					}
					windowOpen = window.open( event.target.getAttribute( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
					return false;
				}
			} );
var windowOpen;
			document.body.addEventListener( 'click', function ( event ) {
				if ( event.target &&
						( event.target.matches && event.target.matches( 'a.share-skype' ) ) ||
						( event.target.msMatchesSelector && event.target.msMatchesSelector( 'a.share-skype' ) ) ) {
					// If there's another sharing window open, close it.
					if ( typeof windowOpen !== 'undefined' ) {
						windowOpen.close();
					}
					windowOpen = window.open( event.target.getAttribute( 'href' ), 'wpcomskype', 'menubar=1,resizable=1,width=305,height=665' );
					return false;
				}
			} );
var windowOpen;
			document.body.addEventListener( 'click', function ( event ) {
				if ( event.target &&
						( event.target.matches && event.target.matches( 'a.share-telegram' ) ) ||
						( event.target.msMatchesSelector && event.target.msMatchesSelector( 'a.share-telegram' ) ) ) {
					// If there's another sharing window open, close it.
					if ( typeof windowOpen !== 'undefined' ) {
						windowOpen.close();
					}
					windowOpen = window.open( event.target.getAttribute( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
					return false;
				}
			} );
var windowOpen;
			document.body.addEventListener( 'click', function ( event ) {
				if ( event.target &&
						( event.target.matches && event.target.matches( 'a.share-tumblr' ) ) ||
						( event.target.msMatchesSelector && event.target.msMatchesSelector( 'a.share-tumblr' ) ) ) {
					// If there's another sharing window open, close it.
					if ( typeof windowOpen !== 'undefined' ) {
						windowOpen.close();
					}
					windowOpen = window.open( event.target.getAttribute( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
					return false;
				}
			} );
</script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20200826#ver=20200826' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script src="//stats.wp.com/w.js?61" defer></script> <script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'45531309','blog_tz':'0','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'45531309','v':'wpcom','tz':'0','user_id':'0','post':'7642','subd':'themeshaper'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1lSiYrZXhzUkM5fD1uTDNLUGt6QzVbd3FKb3Q4aWxFU0VMK3ppSU9RRkVyRmw/bFF4N29ZdnF3Lnxoc0xRaWorQ09SJS14UzNlbj9xNTEsMWpEXSV6VElxbkNoUiUmYzFKWEVNZ184RVZwXTlSfGNnbFI1WiZ+RGxfNmlGYnpmb3pbX3BWK0phTUkxeWp1X2JMZzdkWENaflVEcnlRNEFdXXE5a3MlTy1tRj1zblVXP3YsY1B3QXd8NWpHVW9UQUhuZW89aFVpRyVWbklOUFRBYjdzYk9pdl9yQy50JklaZkY4ZGVofDdjSzddZVQ/UVVjNUMxK3FjTmRQdlpkSGFLUi5CVTBqXThjVkpHZ0ZvMz00ZjclZjVaOX5ddmUuMFlxTWZ0eiw4WSxWWnQuMWhtOWU='}]);
_stq.push([ 'clickTrackerInit', '45531309', '7642' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:1px;width:1px;overflow:hidden;position:absolute;bottom:1px;" alt="" /></noscript>
<script defer id="bilmur" data-provider="wordpress.com" data-service="simple" src="https://s0.wp.com/wp-content/js/bilmur.min.js?m=202052"></script><script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>
